Back to overview
Degraded

CDN Issues

Nov 30 at 01:39pm AWST
Affected services
secure.teamretro.com

Resolved
Nov 30 at 01:39pm AWST

Our logs indicate this issue has been resolved. We will continue to monitor closely.

Created
Nov 30 at 01:39pm AWST

Some users have reported issues loading TeamRetro application pages, due to CDN access issues from specific Points of Presence (CDN PoP). Our teams has cleared our CDN caches and redeployed to immediately resolve the issue; and continues to investigate the root cause.