Back to overview
Downtime
US site unavailable
Nov 01 at 01:21pm AWST
Affected services
secure.teamretro.com
Resolved
Nov 01 at 01:42pm AWST
We've identified the cause of the issue and deployed a fix, services are back online. Our team will continue to monitor closely.
Affected services
secure.teamretro.com
Created
Nov 01 at 01:21pm AWST
Our US environment is currently unavailable with a 503 error. The team is currently investigating and will update shortly.
Affected services
secure.teamretro.com