Back to overview
Degraded

Email Delivery Issues

Mar 30 at 12:01pm AWST
Affected services
secure.teamretro.com
secure.eu.teamretro.com

Resolved
Mar 31 at 12:31pm AWST

Our email provider has resolved the delivery issues, and queued emails are now in the process of being delivered.

Created
Mar 30 at 12:01pm AWST

We are currently investigating an issue affecting email delivery for our platform. This may impact notification emails, password resets, and other system-generated messages. Our team is actively working to identify the root cause and implement a fix.

We will provide further updates as more information becomes available. Thank you for your patience.