Back to overview
Degraded

Issue creating first retrospective / health check

Apr 03 at 03:26pm AWST
Affected services
secure.teamretro.com
secure.eu.teamretro.com

Resolved
Apr 03 at 03:44pm AWST

The issue has been resolved. Thank you for your patience.

Created
Apr 03 at 03:26pm AWST

Some customers have reported Issues creating the first retrospective or health check within a team. The issue has been identified and a fix is currently being deployed.